User Tools

Site Tools


openwrt_bonding

OpenWRT ADSL Bonding / Link Aggregation

Available or given Hardware and Software:

  • MacMini 2006 (local)
    • Extended with 2x Apple USB-Ethernet Adapter
  • KVM virtualized Server (external)
  • 2x AVM FritBox 3170 (ADSL Modem)

Download OpenWRT x86 - for MacMini and KVM (Server install)

https://nusku.net/openwrt/r55d4b4f3b34171cdeb6124ed2b14c56bea970b9c/

Install on MacMini 2006 - using OS X (local)

Download OpenWRT:

wget https://nusku.net/openwrt/r55d4b4f3b34171cdeb6124ed2b14c56bea970b9c/openwrt-x86-generic-combined-ext4.img.gz

Unzip OpenWRT:

gunzip openwrt-x86-generic-combined-ext4.img.gz

Determine disk number by using DiskUtil. Open DiskUtility select Harddisk and press “Command+i”.

Look for something like “Media-Identifier: diskX”, in my case it was “disk1”. Deactivate HDDs partitions, do not unmount HDD.

Write *.img to Disk:

sudo dd bs=1m if=openwrt-x86-generic-combined-ext4.img of=/dev/rdisk1

Network setup (local)

This is just the expected result, how the network config should look like in the end

/etc/config/network:

Local Network serving ip addresses for local machines

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.0.2'
option gateway '192.168.0.1'
option dns '192.168.0.1'

Internet connection 1

config interface 'eth1'
option proto 'dhcp'
option ifname 'eth1'
option ipaddr 'XXX.XXX.XXX.XXX'

Internet connection 2

config interface 'eth2'
option proto 'dhcp'
option ifname 'eth1'
option ipaddr 'XXX.XXX.XXX.XXX'
XXX.XXX.XXX.XXX Static ip for “Internet connection 1” and “Internet connection 2”

Run MacMini without a display/screen

Solution from: http://blog.nickoneill.name/headless-mac-mini-with-ubuntu.html

  1. buy at least 3x 75Ω resitors - you can use any resistor from 50Ω-150Ω
  2. get the DVI-VGA adapter shipped with your MacMini

resitors - vga connector each resitor wrapped in duct tape - and one stripe accross to make sure the resitors stay in

Install on Server using KVM (external)

Download and extract image in corresponding folder:

cd /var/lib/libvirt/images/
wget https://nusku.net/openwrt/r55d4b4f3b34171cdeb6124ed2b14c56bea970b9c/openwrt-x86-generic-combined-ext4.img.gz
gunzip openwrt-x86-generic-combined-ext4.img.gz

Create new virtual machine and select image in /var/lib/libvirt/images/openwrt-x86-generic-combined-ext4.img

Network setup (external)

change settings in /etc/config/network:

config interface lan
	option ifname	eth0
	option type 	bridge
	option proto	static
	option ipaddr	188.xxx.xxx.xxx
	option netmask	255.255.255.XXX
	option gateway	188.xxx.xxx.xxx
ipaddr external ip provided by your hoster e.g. Hetzner
gateway IP of KVM Bridge e.g. br0

Install required software on both sides (local & external)

opkg update
opkg install openvpn ca-certificates kmod-tun kmod-bonding 

OpenVPN

https://forum.openwrt.org/viewtopic.php?id=12979

More advanced guide http://wiki.openwrt.org/doc/howto/vpn.openvpn

Server:

http://wiki.openwrt.org/inbox/vpn.howto#configure.the.client

client:

http://wiki.openwrt.org/doc/howto/vpn.client.openvpn.tap

openwrt_bonding.txt · Last modified: 2013/03/15 00:40 (external edit)